最流行的JavaScript库 jQuery不再支持IE旧版本

时间:2017-11-17 16:03

微软中国官方商城

最流行的JavaScript库,jQuery不再支持IE旧版本



停止对旧版IE的支持,是否会改变jQuery的使用率?答案也许是不会。如果你的网站需要维护对IE8或者低版本(或者是IE9和IE10在兼容模式下运行),你只需要沿用jQuery1.9或者以下版本。

“jQuery2.0主要用于现代网络,”jQuery的Dave Methvin在Query Foundation网站上写道,“我们有jQuery1.x版本处理旧版浏览器,并且期望他可以支持好几年。”

如 果你想要同时兼容新旧版浏览器,你可以使用条件注释,让2.0在新浏览器上使用,而旧版本使用1.9,但是更简单的方法则是沿用 jQuery1.x版本。至少目前2.0的主要用例,对IE的支持是不再考虑范围内了,而是Chrome或者Firefox的附加组件,PhoneGap 应用程序或是node.js

via Nelly@极客标签